Drone keeps losing connection to transmitter

Discussion in 'Specific Models of Quadcopters and Drones' started by Michael Fronczak, Jan 5, 2019.

  1. Michael Fronczak

    Michael Fronczak New Member

    Hello all,

    I'm relatively new to quadcopters and am having an issue.

    About 2.5 years ago, I bought a Blade Inductrix that comes with the transmitter. I installed a camera on it, ran into some other issues and eventually replaced the motors. It worked fine, other than my ability to pilot it.

    Shortly after, we moved so I boxed everything up and it ended up on a shelf in my basement. I recently found it again and wanted to start back up, so I got everything back out, charged up my batteries and went to fly. When I turn everything on, it seems fine but after 8-10 seconds of flying the LED lights on the coptor start to blink and it drops out of the sky and just sits there. If I unplug the battery from the copter, let it sit for about 5 seconds and then plug it back in, it immediately makes connection again but the same thing keeps happening over and over.

    I replaced the batteries in the transmitter with brand new ones, and I've tried all of the LiPo batteries I have for the copter, with no difference. Just to make sure, I purchased five brand new LiPo batteries, charged them up and tried them - same thing. I also went through binding procedure twice, just to make sure. The most time it'll stay connected is about 10 seconds. I have no idea why or how to fix it.
    drone safety likes this.
  2. JonWaltero

    JonWaltero New Member

    There's no solution here. sadly, some devices simply crash about every 5 minutes with the DJIGO4 app, and others don't. Luckily I found a phone that works with it and this never happens anymore. Also was get my drone here - https://www.aeromotus.com/

Share This Page